






ESS 421 
February 9, 2010
Laboratory No. 6: Calibration, Registration & Topographic Correction




Due at end of Lab on Wednesday, February 16th.
In this lab you will use ENVI to perform some of the imaging processing steps that we have been talking about in class.  The instructions in this lab will lead you through the steps required to calibrate, register, and topographically correct an image.

ENVI Basics

Functions in ENVI are accessed through a series of pull-down menus and dialogue windows.  Instructions in bold italics refer to pull-down menus or window buttons.  Bold text refers to named windows, and filenames are given in italics. Online help can be accessed at any time by selecting System > ENVI Online Help.

Open and Display Image File

· Select File > open image file from the menu bar. Open the file named big_pine.bsq (D ( D-temp ( ESS 421 LAB Data ( OWENS ( big_pine.bsq).  This is a portion of a Landsat TM image of Owens Valley, CA from July 7, 1984

· The Available Bands List (ABL) Window will appear showing all files currently open.
· On ABL window, select RGB Color
· Select R: band 5, G: band 4, B: band 3 and Load RGB in Display #1

The Scroll Window shows the entire extent of the image.  A small red box on the Scroll Window corresponds to the portion of the image visible in the Image Window.   A red box on the Image Window shows the portion of the image visible in the Zoom Window.  Practice navigating around the image with the display windows.

· On the Image Window, select tools > Cursor Location/Value  (if this menu is not visible, click on the window with the right mouse button)

The Cursor Location/Value Window shows the cursor’s location (sample #, line #), brightness values sent to the monitor (after stretching), and original DN values of the three bands displayed.

Contrast Stretch

· On the Image Window select Enhance > Interactive Stretching 

· Adjust sliders to achieve desired stretch

Part A, Calibration

Image calibration corrects atmospheric instrument effects and converts instrument DN’s to a physical value.  ENVI has a function that performs an empirical line calibration, relating image pseudo-spectra to measured field spectra of known materials. At least two materials must be known, and it is important to select one bright object and one dark object.  Ideally, you would travel to the field site to determine what is on the ground and take spectral measurements.  Alternatively, you can make assumptions about the composition of some surfaces in the image and use measured reflectance values from a spectral library.  For this lab, you should be able to identify areas on the image which are composed of water, grass, and snow.

· On the Image Window, select tools > Profiles > Z Profile (Spectrum)
The Spectral Profile Window shows the pseudo-spectrum for the pixel in the center of the Zoom Window  (remember that this is uncalibrated data, so the pseudo-spectra include the effects of the atmosphere and instrument gain and offset).  The three displayed bands are represented by colored lines on the plot (vertical axis is DN, horizontal axis is wavelength in microns).

Look for the darkest water you can find on the image (the reservoir in the southeast corner is too shallow).  Snow has high reflectance in the visible, and low reflectance in the infrared (try to find snow that is not completely saturated, i.e. DN < 255).  Grass is characterized by a high peak in reflectance in the near-infrared.

Record the locations and DNs of each material

	material
	sample #
	line #
	DN (band 3)
	DN (band 4)
	DN (band 5)

	water
	
	
	
	
	

	snow
	
	
	
	
	

	grass
	
	
	
	
	


A region of interest (ROI) is used in ENVI to define an image endmember for classification, spectral mixture analysis, or calibration.  You will define three ROIs, each composed of several pixels of one of the above materials.

Region of Interest

· Select Basic Tools > Region of Interest > ROI tool
· The Region of Interest (ROI) Window will appear with options for defining regions
· Select the zoom radio button

· Change ROI_Type to Rectangle
· By navigating in the Scroll and Image Windows, center the Zoom Window on some dark water

· With the left-mouse-button (on the Zoom Window) click and drag a rectangle to enclose several pixels of water

· Click the right-mouse-button so that the rectangle fills with the selected ROI color

· In the ROI Window, click on New Region and follow the above steps to select a region of snow

· Select a region of grass

·  Make sure to edit the names of your regions (water, snow, grass), so that you will be able to identify them later

· After verifying that you have three named regions of the correct materials, save you ROI’s be selecting file > save ROI’s in the ROI window. Write down the file directory and then close the ROI Window.
The ROIs that you just defined are now associated with the currently displayed image.  Before running a calibration, classification, or spectral mixture analysis in ENVI, you need to define ROIs.  ENVI calculates statistics for each of the ROIs in each band.  To calibrate the image data to values of reflectance, mean DN values are compared with library reflectance data.

Empirical Line Calibration
· Select Basic Tools > Preprocessing > Calibration Utilities > Empirical Line > Compute Factors and Calibrate
· Choose the big_pine.bsq file ( ok
Using the Empirical Line Spectra (ELS) Window you will pair the pseudo-spectra from your ROIs with field spectra from a spectral library.

Import ROI spectra:

· Next to Data Spectra, select Import Spectra.

· On the Data Spectra Collection (DSC) Window select Import > from ROI from Input File…
· Click Select All Items, then OK
· Single-click Apply, and close DSC Window.

Import library spectra:

· Next to Field Spectra, select Import Spectra
· On Field Spectra Collection (FSC) Window, select Import > from Spectral Library…
· Open the Spectral Library File named materials.sli( ok
· Select All Items, OK
· Single-click Apply, and close FSC Window
Pair ROI spectra with library spectra:

· Select a region of interest (under Data Spectra) and the most likely library spectra (under Field Spectra) and Enter Pair
· Repeat for all three ROIs.

· On the ELS Window, click OK
· Enter an Output Filename (eg. myname_cal.bsq), leave the Output Calibration Filename blank, and click OK. Write down the file name and its location – you will need this file later.
A plot window named Calibration Factors should show two curves.  Sketch the lower (red) curve below, and close the plot window.  This curve should look somewhat like the relationship between atmospheric scatter and wavelength.  It represents the combined effect path radiance and instrument offset which must be subtracted from image DN values.




· On the Available Bands List (ABL) Window select File > Close All Files
· Close any other stray windows (besides the ABL Window)

· Open and display your newly created calibrated image (eg. myname_cal.bsq). Use the Z_profile tool to verify that the pseudo-spectra of surface materials is as you expect. If so,  you’re ready for Part B…

Part B, Registration

Before performing a topographic correction, an image must be registered to the digital elevation model (DEM).  Open and display (in gray scale) the file named dem.bil.  Try adjusting the stretch, and view the cursor location/value.  The data shown on the histogram and in the Cursor Location/Value Window is elevation above sea level (in meters).  Experiment with Tools > Colormapping > Density Slice on the Image Window.

Record the maximum and minimum elevations in the DEM.  Ignore the outside border of zeros.

	
	elevation
	sample #
	line #

	max
	
	
	

	min
	
	
	


In order to select points on a DEM which correspond to points on an image, it is useful to illuminate the DEM with the same solar geometry as in the image.  In the big_pine.bsq image, the sun is 60( above the horizon and 22( south of east (Sun elevation: 60(, Sun Azimuth: 112().

Creating a Shaded Relief map

· Select Topographic >  Topographic Modeling from the main menu bar

· Choose the dem.bil file > ok
· On the Topo Model Parameters Window Select only [3] Shaded Relief and enter the solar geometry from above.

· Enter a file name (eg. myname​_shade.bil), select OK. Write down this file name and it location.
Now close the dem.bil file and open your new shaded relief image.  This image should look somewhat more like the topography you see in your calibrated image.  Viewing the shaded relief image next to your calibrated image, you should be able to select ground control points from the two images. Close all files.

Selecting Ground Control Points (GCP)

· Open and display the shaded relief image

· Open and display (in a New Display) your calibrated image (either Gray Scale or RGB composite)

· Select Map > registration > select GCP’s: Image to Image
· Choose the Display # containing the shaded relief image for the Base Image
· Choose the Display # containing your calibrated image for the Warp Image > OK
· Center the two Zoom Windows on a common point in both images (stream confluences, ridgetops, peaks, and the edges of water bodies all make good GCPs).

· Select Add Point on the Ground Control Points Selection (GCP) Window to enter a pair. 
Continue adding GCPs until you have about 15 points.  You can click on Show list to display the already selected GCP’s. Delete bad points to improve RMS Error.  As you select more points you can increase the Degree of the transformation to reduce the RMS Error.  You should be able to achieve an RMS Error of less than 1 pixel.

It is important to select points from all regions of the image ON THE SCROLL WINDOW.  When warping with higher order (degree) polynomials, it is especially important to have selected points that completely enclose the area you are interested in.  For areas of high relief, equal numbers of GCPs should be selected from high and low elevations.  When you are satisfied that you have enough points, file > Save GCPs to ASCII… with a unique filename (eg. myname_gcp.pts). Write down the file name and its location.

Record the following information and close the GCP Window.

	# of GCPs
	Degree
	RMS Error

	
	
	


Image Warping

· Select Map > Registration > Warp from GCPs: Image to Image
· Open the GCP file you created above

· Choose your calibrated image as the Warp Image> OK
· Choose your shaded relief image (or dem.bil) as the Base Image> OK
· Select the Warp Method (eg. Polynomial) and Degree
· Choose a Resampling method

· Select Change Output Parameters
· Change Upper Left Corner (X0) and Upper Left Corner (Y0) to zero

· Change Number of Samples to 1123

· Change Number of Lines to 940, OK
· Choose a filename for the warped image (eg. myname_warp.bsq), OK
It is important that the output parameters were changed so that the resulting warped image matches the DEM pixel for pixel (same number of samples and lines).  Now you can clean things up by selecting Close All Files on the ABL Window.  Close all other windows and reopen just your new warped image and the shaded relief image.  If the band names are getting too long to read in the ABL Window, you can edit them by selecting File > Edit ENVI Header from the main menu bar.  Select the offending file and Edit Attributes > Band Names on the Header Info Window (be sure not to change the number of samples or lines).

A useful way to check the quality of your registration and warping job is to view an overlay of the shaded relief image and your warped image.   With both images (myname_warp.bsq and myname_shade.bsq) open and displayed, select tools > Link > Link Displays from either of the Image Windows.  With the displays linked, you can click-and-drag with the left-mouse-button on either the Image Window or the Zoom Window to view an overlay from the other display.  Using this technique, check to see that features on the warped image are aligned with corresponding features on the shaded relief image.  It is especially important that ridgetops be accurately aligned before performing a topographic correction.

If you think your warped image could be improved, Close All Files and follow the steps outlined in Selecting Ground Control Points, opening your old GCP file (myname_gcp.pts) from the GCP Window.  Make sure to again select the shaded relief image (myname_shade.bil) as the Base Image and your calibrated image (myname_cal.bsq) as the Warp Image (do not re-warp the warped image you just created).

Finally, if you think your registration is good enough, you’re ready for Part C…

Part C, Topographic Correction

Assuming the surface materials in Owens Valley have Lambertian properties, you can normalize the effect of changes in illumination angle by applying the following transformation:
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where ’ is the calibrated reflectance on inclined topography,  is the sun zenith angle, and i is the solar incidence angle.  The result () is the normalized reflectance as if the surface were horizontal. 

This transformation can be performed in ENVI using Band Math.   In band math, after entering an expression with multiple variables (b1, b2, etc.), you map specific image files or bands to those variables.  If the expression is valid, it is carried out on a pixel by pixel basis, and a new image file will be created with the result.

In the above expression, ’ corresponds to your warped image file (first calibrated, then warped so it matches the shaded relief image pixel for pixel),  is a constant (sun zenith = (/2 – sun elevation, in radians), and i can be computed from the DEM.

Cosine Correction

Open your warped image (eg. myname_warp.bsq) and the image file named cos_i.bsq (you do not need to display either of these images).  The second file is the cosine of the incidence angle for each pixel in the DEM (which corresponds to each pixel in your warped image).  The sun elevation for the big_pine.bsq image is 60(, so the sun zenith = 0.5236 radians.

· Select Basic Tools > Band Math
· Under ‘Enter an expression’ type b1*cos(0.5236)/b2, select OK
· On the Variable/Bands Pairings (VBP) Window, select B1 – [undefined] and click Map Variable to Input File
· Choose your warped image file (eg. myname_warp.bsq), OK
· Select B2 – [undefined] and Map Variable to Input File
· Choose the cos_i.bsq file, OK
· On the VBP Window, choose an output filename (eg. myname_flat.bsq), OK
Clean things up by selecting Close All Files if you like.  Then open your corrected image (eg. myname_flat.bsq), and display the results.  You will need to stretch the image to be able to see anything.  Try stretching the image with the sliders at zero and one.

Describe the results of the topographic correction

How could the topographic correction be improved?

Why is it important to perform an image calibration before a topographic correction?


Part D, Classification

The purpose of image classification is to assign a name or class to each pixel by comparing spectral characteristics with known materials.  In lecture, we discussed the different types of classification defined by their level of complexity.  Now that you have a calibrated and topographically corrected image, experiment with classifying the image (try Classification > Supervised > Maximum Likelihood).  Before running any classification in ENVI, you have to select ROIs that define your classes (follow steps outlined in Region of Interest).  Obviously, a field trip to Owens Valley would be useful in determining the various scene elements.  Your challenge is to select classes of materials from the image that are abundant and spectrally distinct from each other.

Discuss the results of your image classification below (use the flip side if necessary).

ENVI ‘FUN’ – this part is optional:

Creating a 3D surface

· Open and display your warped & topographically corrected image (the product of part C). 
· Open the DEM file (dem.bil)
· Select topographic > 3D surface from the main menu
· In the ‘Associated DEM input file’ window select dem.bil > ok
· In the ‘3D Surfaceview Input parameters’ window select other  for DEM resolution and fill in the same number as in the image resolution > ok.
· In the new 3D surface window you can select options > Rotate/scale…. to rotate the surface….. . Experiment with the different options. You can save/print the surface from the file menu of this window. 
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